Volume Group Descriptor Area. It contains the information about volume group to which the physical volume belongs to. It also contains the information about physical partitions, logical partitions and logical volumes.
2. What is the login process to the AIX system?
★ AIX is a multi-user system
★ When the user login he needs to provide the user name and password for authentication purposes.
★ After the successful login, AIX starts the SHELL program.
☆ As the user login to the AIX server, the AIX starts the SHELL program.
☆ The SHELL is a command interpreter.
☆ It takes the inputs from the users and executes it.
☆ SHELL is not only the command interpreter it also provide great flexibility to the user.
☆ SHELL not only read and execute the commands it also read the files written in the form of programs and executes them, these shell program files are known as SHELL scripts. The extension of SHELL script is .sh.
4. List the advantages of Bourne Again Shell or bash?
☛ Bash is the GNU shell
☛ Bash is an sh-compatible shell that incorporates useful features from the Korn shell (ksh) and C shell (csh).
☛ It is intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools standard.
☛ It offers functional improvements over sh for both programming and interactive uses.
☛ Interactive usage includes command line editing, unlimited size command history, job control, shell functions and aliases, indexed arrays of unlimited size, and integer arithmetic in any base from two to sixty-four. Bash can run most sh scripts without modification.
5. Explain the various SHELL types?
☷ sh or Bourne Shell
☷ bash or Bourne Again shell
☷ csh or C shell
☷ tcsh or Turbo C shell
☷ ksh or the Korn shell
Volume Group Status Area it contains the information about physical partition from all physical volumes of the same volume group. It contains the status of VG.
7. How to lock a user's account?
#chuser account_lock=true username
8. How do u take backup of file systems?
#backup -f /dev/rmt0
9. What command to restore backup of non - rootvg?
# restvg -x -d -f /dev/rmt0
11. How will u append a file to a previous archive take by Tar?
#tar -rvf /dev/rmt0
12. How will u restore a file from already take backup using backup?
#restore -xvqf /dev/rmt0
13. How to unlock user account?
chuser -a account=true username
14. What are the types of installation in AIX?
❁ New and complete overwrite
❁ Migration
❁ Preservation
15. What are the types of ODM Database?
Pre-defined database PdDv, PdAt
Customised database CuDv, CuAt
16. How to remove a failed package installation?
#installp -C
18. How will you check whether software is installed or not?
# lslpp -L |grep -i (software_name)
19. How will you reject a committed fileset?
# installp -r -g fileset name
20. What is the latest OS level?
#oslevel -rq
21. What are the two states of installation?
❀ Applied and commit state
❀ In applied state if want to do any changes on installed software then we can do.
❀ But in commit the changes are not allowed to do. Once did installation.
❀ A committed fileset update cannot be rejected.
❀ Output from the installp -s command, which is used to get a list of applied software fileset updates and updates that are available to be either committed or rejected.
22. Types of VG & explain about them?
☰ Normal vg -32 pv, 256 lv
☰ # mkvg -y normvg -s 128 hdisk4
☰ Big vg :- 128pv,512lv
☰ # mkvg -B -y bigvg -s 128 hdisk9
☰ Scalable vg: -1024pv, 4096 lv
☰ # mkvg -S -y scalvg -s 512 hdisk1
23. How many VGs can be created in a LVM?
255 any no. of vg can create.
24. How to change a 32 bit kernel to 64 bit kernel?
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX 5.1 or AIX 5.2levels.
# bootinfo -y
It shows a kernel is either 32-bit or 64-bit.
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX 5.1 or AIX 5.2levels.
# bootinfo -y
It shows a kernel is either 32-bit or 64-bit.
To change to a 64-bit kernel, enter the following commands:
# ln -sf /usr/lib/boot/unix_64 /unix
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr
25. How to change a 64 bit kernel to 32 bit kernel?
☛ Modify the /usr/lib/boot/unix directory and the /unix directory to be a symbolic link to the binary for the desired kernel.
☛ Run the bosboot command to write a new system boot image.
☛ Reboot the system.
The path name of the 64-bit kernel is /usr/lib/boot/unix_64, and the
path name of the multiprocessor versions of the 32-bit kernel is
/usr/lib/boot/unix_mp.
☛ # ln -sf /usr/lib/boot/unix_mp /unix
☛ # ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
☛ # lslv -m hd5
☛ # bosboot -ad /dev/ipldevice
☛ # shutdown -Fr
☛ # bootinfo -K (should now be 32)
26. How will you check whether a device is installed or not?
# lsdev -Cc disk
27. Two states of device availability and explain them?
Available state and defined state. When device is in defined state it means it cannot use. Not in ready state. Run cfgmgr try to make available known in the system that device. Available state means that device is ready to use
# lsdev -Cc disk
It displays which disks are available
28. Which file that error daemon stay?
/usr/lib/errdemon
29. When does error demon start in boot process?
rc.boot phase 3
31. What is the command to see the error log?
# errpt -a
# errpt -d H [H/W]
# errpt -d S [S/W]
32. What are the error levels severity?
☻ permanent
☻ Temporary
☻ Informational
☻ Unknown.
33. What are the types of error?
☻ H/W error
☻ S/W error
☻ Operator error
☻ Unknown error.
34. How to enable & disable quorum?
# chvg -vy pv_name
# chvg -vn pv_name
#chvg -Qn vgname
#chvg -Qs vgname
35. What will you do if a disk gets failed?
diag command