1. How to unfreeze the svcgroup, (enable onl. & offl.)?

#haconf -makerw
#hagrp -unfreez SG -persistent
#haconf -dump -makero

2. How to check the connectivity between 2 nodes?

Get the mac address from both the nodes

#getmac /dev/qfe:0

Sv from server side

Cv from client side

#./dlpiping -sv /dev/qfe:0 macaddresss

#./dlpiping -cv /dev/qfe:0 macaddresss

3. How to stop the VCS?

Stop the cluster on the local server but leave the
application/s running, do not failover the application/s
#hastop -local

Stop cluster on local server but evacuate (failover) the
application/s to another node within the cluster
#hastop -local -evacuate

Stop the cluster on all nodes but leave the application/s
running
#hastop -all -force

4. Explain What are the service group dependence?

4types

Online local

Online remote

Online global

Offline global

5. Explain SUN CLUSTER offline cluster resources on smslu131?

verify resources are online on tgui1-svc

# scstat

Take all resources offline

# scswitch -F -g smsweb-rg

verify resources are offline on both tgui1 & tgui2

# scstat

verify resources are offline on tgui1-svc & tgui2-svc

# scstat

switch resources online on smslu131

#scswitch -Z -g smsweb-rg

verify resources are online on tgui1-svc

#scstat

verify resources are online on tgui1-svc

# scstat

switch resources from smslu131 to smslu132

# scswitch -z -g smsweb-rg -h tgui2-svc

verify resources are online on tgui2-svc

# scstat

switch resources from smslu131 to smslu132

# scswitch -z -g smsweb-rg -h tgui1-svc

verify resources are online on tgui1-svc

# scstat

6. How to delete a service group?

1. Check the Service Group dependancy with other service
group
#hares -dep <Service Group>
2.to make the cluster configuration to read write mode.
haconfig -dump ro
3.Switch the online Service groups to the other system.
#hagrp -switch <Service group> -to <host2>
4.Make the Service group stable on other Host or freez them
on other node:
#hares -freeze <Service group> -sys <host2>
5.Make the service group offline on host1
#hagrp -disable <service group> -sys <host1>

7. How to add a server group?

#haconf -makerw

#hagrp -add groupname

#hagrp -modify groupname systemList -add node1 node2

#haconf -dump -makero

8. Suppose main.cf files corrupted how will you rectify?

We can recreate a corrupt main.cf configuration file using the below two files.

1)main.cf.previous
2)main.cmd

9. How to identify VXVM version?

If running on solaris use following command to get vxvm version-
pkginfo -l packagename

10. What the path of scconf in cluster?

/usr/cluster/bin/scconf is the path in suncluster

Download Interview PDF

11. Whenever you are creating a new user file /etc/passwd file inode number will be changed why?

Whenever we add user the file "/etc/passwd", "/etc/shadow"
and "/etc/group" is regenerated.

and when we assign/change the password the file
"/etc/shadow" will regenerated.

12. Explain command to display default boot device?

In ok prompt,we can use printenv command...
ok printenv boot-device

In shell prompt,
#eeprom | grep boot-device
or
#prtconf -vp

13. What is the difference between init runlevel and milestone?

Upto solaris 9 runlevel are used they are

Runlevel 0 1 2 3 4 5 6

In solaris 10 milestone is introduced. Milestone is
improved level of runlevel

In run level we use init 1 to bring system into single
user, in milestone # svcadm milestone single-user command
used to bring the system to single user Simillarly

init 2 as multi-user(more than one user),init 3 as multi-
user-sever provide multiuser mode along with nfs

runlevel 4 is currently unused

runlevel 5 ie init 5 shutdown and power off

runlevel 6 ie init 6 shut down and restart

14. How system identify run level at boot time?

After initialization of kernal it self next init phase
starts. Here kernal reads init level from /etc/inittab file.
in solaris 9 but in solaris 10 svc.startd deamon starts
mailstone serviceses

15. How to view the kernel (shmmax) parameter value in Solaris 10?

To view the current values of the resource control, enter
the following commands:

#id -p //to verify the project ID
uid = 0 (Root) gid = 0 (Root) projid = 1 (user.root)
#prctl -n project.max-shm-memory -i project user.root
#prctl -n project.max=sem-ids -i project user.root

16. Suppose /etc/system file file got deleted how you will
regenerate from ok prompt in Solaris?

if /etc/system file deleted take the back-up of file.if at
all no back-up copy /dev/null file to /etc/system in ok
prompt and it copies default files to /etc/system.

17. How do you replace a failed boot disk under Meta in Solaris? Step by step explanation?

1) Checks the disks available: #metastat -p
2) Detach the one with errors: #metadetach d1 d2
If you get error here : #metadetach -f d1 d2
3) Now check the status again: # metastat -p

18. What you would do if you want to replace a slice using metareplace option?

We use metareplace usually when we have have faulty
submirrors and once replaced it resyncs with the failed
components.
1) Find the meta state databases on the slice
#metadb -i
2) If any meta state databases exist remove them
#metadb -d c0t0d0sX where x is slice number
3) Once the meta state databases are removed we can use
cfgadm to unconfigure the device
#cfgadm -c unconfigure diskname
Once unconfigured replace the disk and configure it as
below
4)#cfgadm -c configure diskname
5) Now copy the Volume Table Of Contents (VTOC) to the new
disk
#prtvtoc /dev/rdsk/devicename | fmthard -s -
/dev/rdsk/devicename
6) Once the VTOC is in place now use metareplace command to
replace the faulty meta devices
#metareplace -e d11 devicename ( Where d11 is the
meta device )

19. What is the significance of 51% state database replicas in SVM?

A state database is the collections of multiple,
replicated database copies and each copy is considered as a
state database replica.
If the solaris box loses a state database replica, SVM
should figure out which state database replicas still
contain valid data and boot using the valid ones and this
is achieved by using “majority consensus algorithm” and
according to this algorithm we need half+1 number of state
database replicas before it finds for a valid data.
And for the above reason we need to recreate at least three
state database replicas when we setup a disk configuration.
If all the three database replicas are corrupted meaning we
lose all data stored on svm volumes.
Hence its good to create as many replicas on separate
drives across controllers.

20. Explain What are the common errors you find in Solaris Volume manager?

1) Disks failures (Boot device failures)
2) Insufficient state database replicas issues
3) Wrong entries in /etc/vfstab file

21. Suppose You have a boot disk under svm, the machine fails to boot and remains in ok prompt? what could be the possible reason?

1) May be issue with /etc/system file
2) Root file system corrupted
3) Wrong entries in /etc/vfstab file

22. How to create a shared disk group in VxVM?

Creating shared dg form the existing dg’s
1) List all the dg available: #vxdg list
2) Find out the node that is master or slace using:
#vxdctl -c mode
3) Deport the disk groups to be shared: #vxdg deport
<dg name>
4) Import dgs to be shared: #vxdg -s import < dg
name> % Do this on master node
5) To check the shared disk groups: #vxdg list

23. What is the difference between private and public regions in Veritas Volume manager?

Private Region: It has meta data regarding the disk. A
copy of the configuration database is copied to each
private region with the disk group. It keeps 5 copies of
the configuration database. It is configured as slice 3.
Once the private region is created it cannot be changed.
Public region: This is the area where all users' data is
stored. Usually it is configured as slice 4.

24. How to convert a volume from gen to fsgen? why
should you do that?

1) #vxprint -g dgname -rhmvps filename >
filename.vxoutput
2) open the file simplevol.vxout using your fav editor and
change the use_type field alone from gen to fsgen.
3. Save the file. make sure you edit the use_type field
alone…
4. Umount the filesystem; umount /simplevol
5. stop the volume ; vxvol -g dgname stop simplevol
6. remove the volume ; vxedit -g dgname -rf rm simplevol
7. using vxmake rebuild the volume from the saved file ;
vxmake -g dgname -d simplevol.vxout
8. check the vxprint out; vxprint -g dgname -hrt ; check
for the usage type; it would be fsgen
9. start the volume; vxvol -g dgname start simplevol
10. do a fsck for the volume; fsck -
y /dev/vx/rdsk/dgname/simplevol
11. mount the filesystem ; mount /simplevol
gen assumes a volume does not contain filesystem and fsgen
assumes a volume contains a file system. Vxassist uses
fsgen as default type and vxmake uses gen as default type.

Download Interview PDF